PHP/IonCube

Aus schokokeks.org Wiki
< PHP
Wechseln zu: Navigation, Suche

Gelegentlich erhalten wir Anfragen von Kunden, die proprietäre PHP-Anwendungen installieren möchten und nun mit der Installation eines "IonCube Loader" oder des "Zend Optimizer" konfrontiert werden. Insbesondere bei Web-Shop-Systemen scheint dies stark verbreitet zu sein.

Bei diesen proprietären PHP-Erweiterungen handelt es sich um Programme, die verschlüsselten PHP-Code zur Laufzeit entschlüsseln. Dies dient dazu, es dem Nutzer unmöglich zu machen den PHP-Quellcode anzuschauen oder zu verändern.

Diese Erweiterungen funktionieren bei uns nicht.

Wir setzen auf unseren Servern nur freie Software ein und empfehlen unseren Kunden, dies ebenfalls zu berücksichtigen. Nur bei freier Software können Sie (oder unser Support) im Falle von Fehlfunktionen reagieren, den Fehler suchen und beheben.

Für Kunden, die trotzdem die Einschränkungen proprietärer Software akzeptieren möchten, bieten wir das Hosting auf einem eigenen Server an, der nach Kundenwunsch mit der benötigten Software ausgestattet wird und die Sicherheit der anderen Kunden nicht beeinträchtigen kann.